Linux

NVIDIA 435.17 Linux Beta Sürücüsü Vulkan ve OpenGL + GLX İçin PRIME Boşaltma Eklendi


NVIDIA Talep Üzerine PRIME boşaltma

En son NVIDIA 435.17 Linux beta sürücüsü PRIME render boşaltması için Vulkan ve OpenGL + GLX desteği eklendi.

PRIME, Linux çekirdeğinde, ekran sunucusunda ve NVIDIA Optimus (entegre bir Intel GPU ve ayrı bir NVIDIA GPU kullanan) kullanan dizüstü bilgisayarlar gibi, Linux altında çoklu GPU yapılandırmalarıyla GPU boşaltımını mümkün kılan çeşitli sürücü özellikleridir.

İsteğe bağlı yeni PRIME render boşaltması sayesinde, entegre GPU'yu her şey için kullanırken, pil gücünden tasarruf sağlayarak ayrık NVIDIA GPU'da özel bir uygulama çalıştırabilirsiniz.

En son NVIDIA 435.17 Linux beta sürücüsü PRIME için Vulkan ve OpenGL + GLX desteği sağlar, ancak NVIDIA'nın EGL'i henüz desteklenmiyor.

En yeni beta NVIDIA sürücüsünün yeni PRIME render boşaltma özelliğini kullanmak için, Henüz herhangi bir resmi X Server sürümünde henüz yayınlamadıysanız yamaları olan bir X Server'a ihtiyacınız olacak.olsa bir PPA Ubuntu için 19.04 veya 18.04 sınavı isteyenler için teklif edildi (ancak NVIDIA Sürücüler PPA şu anda Ubuntu 19.10 için yalnızca 435.17 sürümüne sahip, bu nedenle daha eski bir sürüm kullanıyorsanız beklemeniz gerekecek). Bazı ekstra X ekran yapılandırması (xorg.conf) da işlerin yürümesi için gereklidir.

Grafiksel uygulamaların NVIDIA GPU ekranına boşaltılması gibi göründüğünü de belirtmek gerekir, çalıştırmaya çalıştığınız uygulamanın türüne bağlı olarak bazı ortam değişkenleri gerekir:

  • Vulkan uygulamaları için kullanmanız gerekecek __NV_PRIME_RENDER_OFFLOAD=1 (Örneğin.: __NV_PRIME_RENDER_OFFLOAD=1 vkcube)
  • GLX uygulamaları için her ikisini de kullanmanız gerekir __NV_PRIME_RENDER_OFFLOAD=1 ve __GLX_VENDOR_LIBRARY_NAME=nvidia (Örneğin.: __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia glxinfo | grep vendor).

Hakkında daha fazla bilgi NVIDIA 435.17 Linux beta sürücüsündeki değişiklikler ve kontrol PRIME detayları ve gereksinimleri boşaltma yapar.

Eski Nvidia Optimus dizüstü bilgisayarım en son NVIDIA sürücülerini desteklemiyor (eski 390 sürümünü kullanmam gerekiyor), bu yüzden bunu test edemedim; bu yüzden NVIDIA Ayarları ekranımda yeni “NVIDIA İsteğe Bağlı” seçeneği var, ancak başka bir ayar yok. Bu nedenle, bunu ayarlamak ve kullanmak için herhangi bir ekstra ayrıntı veya uygun, test edilmiş bir yöntem sunamıyorum.

üzerinden / R / linux_gaming (/ U / Anti-Ultimate)

Daha Fazla Göster
Kapalı